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C H A P T E R  1

Welcome

Welcome to Installation Manager for MetaFrame XP with Feature Release 3. 
Installation Manager is the Application Packaging and Delivery feature of 
MetaFrame XP that lets you easily install application packages on the servers in 
your MetaFrame XP server farm from a central location.
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Installation Manager Documentation
The MetaFrame XP documentation set includes electronic manuals and online 
application help for Installation Manager.

On a MetaFrame XP server, the Installation Manager documentation is located in 
the Documentation folder. You can display the contents of this folder in Program 
Files\Citrix\Documentation on your local drive.

The following Installation Manager documentation is included with MetaFrame 
XP:

• This manual, Installation Manager for MetaFrame XP Administrator’s Guide, 
provides conceptual information and basic procedures for system administrators 
who install and uninstall Installation Manager, create packages, and install 
packages on target servers. To get the most out of this manual, review the table 
of contents to familiarize yourself with the topics included in this book.

• Online help for the Management Console for MetaFrame XP and for Packager 
provide detailed steps about how to use Installation Manager. You can access 
the online help from the Help menu in the Management Console or in 
Packager’s main window. See the online help for specific tasks.

Note Packager and its online help are available in English and Japanese only.

• The Installation_Manager_Readme.txt file contains last minute updates, 
corrections to the documentation, and a list of known problems. This file is in 
the \Docs directory of the MetaFrame XP Server CD-ROM.

• A supplementary manual, Citrix Installation Manager Application 
Compatibility Guide, provides useful information about specific compatibility 
issues that occur if you package, install, or uninstall applications using 
Installation Manager. This guide is available on the Citrix Web site at http://
www.citrix.com/support in Product Documentation.

MetaFrame XP documentation is available in the following locations:

• In the \Docs directory of your MetaFrame XP Server CD-ROM.

• Installed in the Documentation folder of your MetaFrame XP server, 
<drive>:\Program Files\Citrix\Documentation.

• On the Citrix Web site at http://www.citrix.com/support/ (select Product 
Documentation). You can check the Product Documentation area of the Web 
site at any time for the latest updates to Citrix technical manuals. Any updates to 
the manuals published after the release of this product will be posted there.
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Using PDF Documentation
To access the documentation that is provided in PDF files, use Adobe Acrobat 
Reader 4 or later. Acrobat Reader lets you view, search, and print the 
documentation.

You can download Acrobat Reader for free from the Adobe System Web site at 
http://www.adobe.com/. The self-extracting file includes installation instructions.

Documentation Conventions
Citrix documentation uses the following typographic conventions for menus, 
commands, keyboard keys, and items in the program interface:

Convention Meaning

Boldface Commands, names of interface items such as text boxes and option 
buttons, and user input.

Italics Placeholders for information or parameters that you provide. For example, 
filename in a procedure means you type the actual name of a file. Italics 
also are used for new terms and the titles of books.

UPPERCASE Keyboard keys, such as CTRL for the Control key and F2 for the function 
key that is labeled F2.

Monospace Text displayed in a text file.

%SystemRoot% The Windows system directory, which can be WTSRV, WINNT, 
WINDOWS, or other name specified when Windows is installed.

{ braces } A series of items, one of which is required in command statements. For 
example, { yes | no } means you must type yes or no. Do not type the 
braces themselves.

[ brackets ] Optional items in command statements. For example, [/ping] means that 
you can type /ping with the command. Do not type the brackets 
themselves.

| (vertical bar) A separator between items in braces or brackets in command statements. 
For example, { /hold | /release | /delete } means you type /hold or
/release or /delete.

… (ellipsis) You can repeat the previous item or items in command statements. For 
example, /route:devicename[,…] means you can type additional 
devicenames separated by commas.

! Step-by-step procedural instructions
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Citrix on the World Wide Web
The Citrix Web site, at http://www.citrix.com/, offers a variety of information and 
services for Citrix customers and Citrix MetaFrame users. From the Citrix home 
page, you can access Citrix online Technical Support Services and other 
information designed to assist MetaFrame XP administrators, including the 
following:

Citrix Documentation Library. The library, which contains the latest documentation 
for all Citrix products, is at http://www.citrix.com/support/ (select Product 
Documentation). You can download updated editions of the documentation that 
ships with Citrix products, as well as supplemental documentation that is available 
only on the Web site.

Citrix ICA Clients. Downloadable Citrix ICA Clients (at http://www.citrix.com/
download).

Support Options. Program information about Citrix Preferred Support Services 
options is available in the Support area of the Citrix Web site at 
http://www.citrix.com/support.

Software Downloads. An FTP server provides access to the latest service packs, 
hotfixes, utilities, and product literature for download.

Online Knowledgebase. An online Solution Knowledge Base contains an extensive 
collection of application notes, technical articles, troubleshooting tips, and white 
papers.

Discussion Forums. The interactive online Solution Forums provide outlets for 
discussion of technical issues with other Citrix MetaFrame users.

FAQs. Frequently Asked Questions (FAQ) pages provide answers to common 
technical and troubleshooting questions.

Education. Information about programs and courseware for Citrix training and 
certifications is available at http://www.citrix.com/training/.

Contact Information. The Citrix Web site provides contact information for Citrix 
offices, including the worldwide headquarters and headquarters from Europe, Asia 
Pacific, and Japan operations.

Developer Network. The Citrix Developer Network (CDN) is at 
http://www.citrix.com/cdn/. This open enrollment membership program provides 
access to developer tool kits, technical information, and test programs for software 
and hardware vendors, system integrators, ICA licensees, and corporate IT 
developers who incorporate Citrix computing solutions into their products.
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SDKs. The Citrix Server Software Development Kit (SDK) is available for free 
from http://www.citrix.com/cdn/. Most of the operations that you can perform 
through Citrix GUI tools can be scripted by using the Citrix Server SDK. The SDK 
also lets programmers customize most aspects of MetaFrame XP.

Providing Feedback About this Guide
We strive to provide accurate, clear, complete, and usable documentation for Citrix 
products. If you have any comments, corrections, or suggestions for improving our 
documentation, we want to hear from you. 

You can send e-mail to the documentation authors at documentation@citrix.com. 
Please include the product name, version number, and the title of the document in 
your message.
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Introduction to Installation Manager

Installation Manager is a powerful feature in MetaFrame XPe that facilitates the 
rapid installation of applications and other software components. 

Installation Manager lets you install applications and other software components to 
any or all available servers in your farm—attended or unattended—using any 
MetaFrame XP server on the network regardless of physical location, network 
connection type, or hardware setup.

This chapter covers the following topics:

• Why you should install Installation Manager

• An overview of package deployment

Why You Should Install Installation Manager
Imagine the administrative burden of installing Microsoft Office 2000 on 200 
servers by sitting in front of each server and manually installing every piece of the 
software. The thought is daunting. It can take weeks to complete the task only to 
find that you have to begin the cycle again. Six months later, you have to upgrade 
these servers with the latest service packs or software patches. Installing the files 
can become an endless task.

Installation Manager lets you install an application package, such as Microsoft 
Office 2000, from one server to all the servers in a domain or in a farm. Use 
Installation Manager to deploy applications, files, service packs, or software 
patches on the servers in your farm.

Installation Manager provides the following advantages:

Install and publish applications quickly and conveniently. Installation Manager 
includes enhancements to published applications. These enhancements give the 
application publishing feature the ability to push application installations to servers 
and publish those applications when scheduled. Further, unpublishing an 
application does not uninstall the package in which the application resides.
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Create or change an ADF package. Installation Manager allows you to create 
packages as ADF files (a package format) or change existing ADF packages (a 
package type) to include updated files.

Install applications, service packs, patches, and upgrades. Installation Manager 
installs applications, service packs, patches, or upgrades to existing applications. In 
addition, you can replace a corrupted application.

Install existing packages. You can add to and install ADF or MSI packages built by 
other software products from Installation Manager.

Customize packages. ADF packages are fully customizable. A set of Packager 
commands lets you change an ADF file at the command prompt.

Schedule packages. You can schedule package installations on target servers in 
farms or change the order of the packages you install.

View package information. You can view the contents of a package, schedule the 
package to install or uninstall, or view the status of the package. The Management 
Console tree view displays the current status and other information about the 
package.

Manage packages. You can manage package installations and uninstallations in the 
farm or across domains. You can schedule new application installations for any 
time, such as when farm usage is low or when a new application becomes available.

Install an application remotely without installation rewrites. Installation Manager 
includes its own monitoring utility that lets you replay any application installation 
without modifying the install program in the application. Packager frees you of any 
dependency on application vendors to package their applications in a way that is not 
compatible with Installation Manager.

Save time. You can save a significant amount of time installing packages on 
servers in the farm from a central location, using the Management Console.

Restart servers automatically. You can automate server restarts immediately after 
an application installs on the target server, making the application and the server 
ready for use.

Run the same software in Citrix ICA Client sessions. All Citrix MetaFrame users in 
the farm or across farms can be assured that they are running the same version of an 
application. Running the same application version resolves application 
compatibility problems if multiple users access the same files.

Make internationalization easier with UNICODE compatibility. Installation Manager is 
UNICODE compatible, solving problems with internationalization.
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Add compatibility scripts in ADF packages. You can add an application 
compatibility script to any ADF package as you create your package.

Add transform files in MSI packages. You can add a transform file to any MSI 
package.

Replace damaged applications. You can replace a damaged application quickly on 
all affected servers by uninstalling the package and installing a new packaged 
application, or forcing the reinstallation of the package.

Note If you uninstall a program on a server locally without the use of Installation 
Manager, the program may still appear to be installed in the Management Console.

Overview of Package Deployment
You can use Installation Manager to install a number of different software types: 
applications, service packs, upgrades, application suites, patches, or other files as 
packages. A package can include combinations of these software components. For 
example, the package can include an application and a patch file or an application 
and other related files. You can combine several related packages into a package 
group, such as packages that include various types of accounting applications or 
packages created specifically for a department or workgroup. Combining packages 
makes them easier to categorize and faster to locate.

To deploy a package to MetaFrame XP servers, you need to:

1. First select the servers on which you want to install the application. These are 
known as the target servers. 

2. Decide the package format you want to use. Installation Manager supports three 
package format types: ADF, MSI, and MSP.

• You can create an ADF package using Packager in Installation Manager. 
ADF packages work well for silent (unattended) installations, application 
recordings, or other files that do not require a recording. A recording 
contains an application’s installation routine for replay on target servers.
An ADF package can include a new application, the upgrade to an existing 
application already installed on your target servers, or other files that your 
Citrix MetaFrame users require. The ADF file has a .wfs extension.
Some applications, such as Microsoft Project 98, require that a compatibility 
script be added to the package for successful installation on target servers. 
Packager can add a compatibility script prior to the build process.
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• An MSI package is created by a software manufacturer or by using a 
software packaging product that builds MSI packages. MSI packages work 
well for application suites such as MetaFrame XPe where several 
components are included in the package.
MSI packages sometimes use transform database files. Transform files act 
like filters that you apply to MSI packages. These files modify instructions 
about how a package is installed; for example, to enable an application to 
run on Terminal Services.

Note You cannot edit MSI packages or transform files using Packager. Use a 
packaging product that can edit these file types.

• An MSP package is created by a software manufacturer or by using a 
software packaging product that builds MSP packages. These are typically 
used to patch or update application installations that use the Windows 
Installer service for packaging.

3. Install the correct Installation Manager components. You need to:

• Install the Installation Service on each target server. This is installed 
automatically when you install MetaFrame XP.

• Install Packager on the server you want to use to create the package (if you 
want to create ADF packages). 

• Install the Management Console on the MetaFrame servers you are going to 
use to manage the installations. 

4. Obtain or create the package. 

5. Add the package to MetaFrame XP and schedule when you want to install and 
publish the application.
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The following illustration shows a simple farm configuration with Installation 
Manager components.

Server A Server B

 

Network share point
(stores packages)MetaFrame XPe

with Packager only
(creates ADF packages)

MetaFrame XPe
with the Citrix Installer
Service and Installation
Manager subsystem

(target server - 
installs packages)

Server C
MetaFrame XPe with the
Management Console 
.
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Installing Installation Manager

This chapter explains how to install and upgrade Installation Manager. This chapter 
covers the following topics:

• Requirements

• Preparing to install the product

• Installing Installation Manager components

• Using Installation Manager in the Management Console

• Granting administrators access to Installation Manager

• Uninstalling Installation Manager

Requirements
To package applications and run Installation Manager, you need to assign servers 
for the following tasks:

To: You need:

Create packages in ADF format (if required) A server to run Packager.

Manage Installation Manager packages from 
the Management Console

A MetaFrame XPe server with the 
Management Console installed for package 
management. This is known as a package 
management server.

Store the packages waiting to be installed A file server that functions as storage on a 
network share point for ADF and MSI 
packages. This is known as the network share 
point server. 

Install the packages on the MetaFrame 
servers

MetaFrame XPe and Installation Manager 
installed on each target server.
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Requirements for MetaFrame XPe Servers
The requirements for MetaFrame XP and the Management Console for MetaFrame 
XP are listed in the MetaFrame XP Server Administrator’s Guide. 

Requirements for the Packaging Server
To create ADF packages, Citrix recommends that you install MetaFrame XPe and 
Packager on a separate system dedicated to packaging only. Where possible, run 
Packager in an environment that closely approximates the environment of the target 
servers.

If you build ADF packages on a separate server, it is not necessary to install 
Packager on more than one server in the farm.

Note With MetaFrame XP with Feature Release 2 or later, you cannot package or 
deploy applications using Windows NT Server 4.0 Terminal Services Edition. 

Packager requires over 4933KB of disk space, in addition to the Windows operating 
system requirements and the disk space required to package any applications, 
service packs, and other files. During packaging, all of the component files are 
copied to a package source directory. As much disk space used for the component 
files is needed for the package source files. For example, if you package an 
application that totals 10MB, you need an additional 10MB of disk space for the 
package source files.

The server used as the packaging environment must include: 

• A partition on the hard drive dedicated only to packaging applications. The 
partition must be at least 500MB and must not contain any files or data other 
than those required by Installation Manager.

• A Windows operating system installed on the partition. This operating system 
must be a fresh installation of Windows 2000 Server.

Important This installation cannot be an existing installation of Windows 2000 
Server. Use this installation exclusively for the purpose of packaging 
applications and not for any other work-related tasks.

• Packager installed on the same partition. This software is included on the 
MetaFrame XP Server CD-ROM.
Set up your rights in Windows so that you can install the packages on your 
target servers successfully. See the Windows documentation for information 
about setting up these rights.

Before you create and build packages in Packager:
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• Create a Windows network share point to serve as a repository for your 
packages.

• Create a Windows domain account that has a minimum of Read and Write 
access rights to the network share point. See "Planning Your Installation" on 
page 20 for more information. If you record an installation that requires 
administrator rights, you need those rights before you can begin the 
packaging process.

• Create a network account in the Management Console to add your package 
to the Installation Manager database, making the package ready to schedule 
the installation. See "Granting Access to MetaFrame Administrators" on 
page 23 for more information.

Requirements for the Network Share Point Server
Your file server must:

• Have adequate free disk space to hold all of the packaged applications and other 
software components (such as service packs or upgrades) that you plan to 
install. The disk space required for each application is almost the same as that 
recommended by the software manufacturer (some additional disk space is 
required for registry entries, dlls, .ini files, and so on, during and after the build 
process).
For example, an application that requires 40MB of disk space for a local 
installation requires just over 40MB of free space on the file server.

• Support Universal Naming Convention (UNC) share points.

• Be accessible to all servers using Installation Manager to install applications. If 
you publish applications from packages, you must have Read and Write access 
to this file server.

Important Read and Write permissions must be set at the network share point to 
allow you to copy packages to that share point and retrieve them for deployment on 
the target servers. The user accounts for adding and retrieving packages must have 
local administrative rights. See the Windows documentation for more information.

Requirements for the Target Servers
To install applications on the target servers in your network, the servers must have 
MetaFrame XPe and the Installer Service installed.
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Planning Your Installation
Carefully plan which component you want to install on the servers that will use 
Installation Manager.

For example, if you have five servers in your farm, you can install:

• Packager on a MetaFrame XP server for packaging

• The Management Console and Installation Manager on a MetaFrame XPe 
server for package management

• The Installer Service and the Installation Manager subsystem on three 
MetaFrame XP target servers

Setting up your environment for application installation includes these general 
tasks: 

• Install MetaFrame XPe, the current feature release, the current Management 
Console for MetaFrame XP, and the necessary Installation Manager 
components on the servers in your farm.

• Install the Citrix Installer Service on target servers that will receive packages.

• Set up a domain account. A Windows 2000 Server domain account must be set 
up as the Installation Manager administrator account. Configure this account on 
the Management Console.

• If you install an unattended program on the Management Console and the 
program requires local administrator rights, the Installation Manager network 
account must have the same rights. Applications generally do not require the 
user to have administrator rights. 

• The network account will also be used by the Installer to deploy packages; you 
must verify which applications will and will not require administrator rights.
To set up the rights, use the following options in Windows 2000 Server: from 
the Start menu, click Programs > Administrative Tools > Computer 
Management.

• To install MSI or MSP packages, you can add and schedule the package in the 
Management Console. No setup is required other than placing the packages on a 
network share point.
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• To create ADF packages, set up the packaging server for building ADF 
packages by installing Packager on a MetaFrame XPe server in your farm. If 
you create ADF packages from an installation recording, this server must be a 
clean server. A clean server does not contain any applications that the target 
servers do not have. All applications you want to add to the package must be 
installed during the packaging session. The recording process does not add any 
files to the ADF packages that were on the server before the recording process 
began. 

Note Only one recording is allowed for each package you create.

For example, if the file Mfc42.dll (required by an application that you want to 
package) is on the clean server before packaging begins, Mfc42.dll is not added 
to the package. The application runs correctly if Mfc42.dll exists on the target 
server before you install the package. If Mfc42.dll is not on the target server, the 
application will not run after it is installed.

• Make sure the Packager server operating system and its environment matches 
the environment of the MetaFrame XP servers on which you install your 
applications. 

Installing Installation Manager Components 
Use the following procedure to install or upgrade Installation Manager. You need to 
follow this procedure for each server in your farm.

Note This setup procedure focuses primarily on Installation Manager installation; 
the general MetaFrame XPe installation steps are not described in detail. See the 
MetaFrame XP Server Administrator’s Guide for complete MetaFrame XPe 
installation instructions.

" To install Installation Manager on a server

1. Log all users off the server.

2. Close all applications on the server, including the Management Console.

3. Insert the MetaFrame XP Server CD-ROM in your CD-ROM drive:

• If your CD-ROM drive supports Autorun, the MetaFrame installation splash 
screen appears.

• If the splash screen does not display, click Run from the Start menu and 
type d:\Autorun.exe, where d is the letter of your CD-ROM drive.

4. Click the Install or update MetaFrame icon.
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5. Click either the MetaFrame XP Feature Release 3 or MetaFrame XP Service 
Pack 3 icon. The installation wizard starts.

6. When MetaFrame XP Setup begins, a series of information pages and dialog 
boxes ask you to select options and configure MetaFrame XP. Click Next to 
continue after you complete each entry. If you want to return to a previous page 
to make changes, click Back. If you click Cancel, Setup stops without 
finishing.

7. When the Component Selection page appears, click Installation Manager and 
select the component you want to install. Click OK.

8. At the prompt, click Restart to restart the server.

Using the Management Console to Manage Packages
The Management Console with Installation Manager can manage ADF, MSI, or 
MSP packages. Authenticated administrators can use the Management Console to:

• Grant access to domain administrators

• Change user rights

• Configure network share user accounts

• Create server or package groups

• Add packages to the Installation Manager database

• Schedule or edit package scheduling for installation on target servers

• Install packages on target servers

• Monitor installation status

• Uninstall packages from target servers

Starting the Management Console
" To use the Management Console

1. From the Start menu, choose Programs > Citrix > Management Console.

2. When the Management Console starts, a dialog box asks you to log on to the 
farm. Type or choose the MetaFrame XP server name, user name, password, 
and domain. Click OK.

" To view online help in the Management Console

From the Help menu, choose Contents and Index. You can press F1 in the 
interface to access help if preferred.
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Granting Access to MetaFrame Administrators
You can control the management of server farms by controlling access to the 
Management Console. The Management Console uses standard Windows user 
authentication. By default, all users who are included in the server’s local 
Administrators group can log on to the server and use the Management Console to 
manage package installations to server farms.

To give a user authorization to manage target servers, add the user account to the 
local Administrators group. By default, members of the global Domain 
Administrators group are included in the local Administrators group on each server, 
so your domain administrators have access to the servers in the domain. You can 
change the users who have access by changing user and group accounts.

" To configure the domain account in the Management Console

Configure the Windows 2000 Server domain account as the Installation Manager 
administrator account.

1. Log on to the farm and start the Management Console.

2. At the top of the Management Console tree, click the farm name item.

3. Right-click Installation Manager and choose Properties.

4. Click the Network Account page.
Configure settings for the default network credentials.

See the Installation Manager online help for more information about setting up a 
network share point user account.

See the Windows documentation or online help for more information about user 
accounts and groups.

Uninstalling Installation Manager
You can uninstall Installation Manager by running the installation program for 
MetaFrame XPe, selecting Install or update MetaFrame, and modifying the 
installation to remove the components of Installation Manager. Alternatively, you 
can remove the entire installation of MetaFrame XPe.

Before you uninstall Installation Manager:

• Log off any currently connected Citrix ICA Clients and the Management 
Console, and exit all programs executing on the Windows server.

• If Installation Manager is still running on another server in the farm, the 
Installation Manager folder still appears in the Management Console even 
though it is empty. This does not cause any harm.



After you uninstall MetaFrame XPe and Installation Manager:

• If you plan to reinstall Installation Manager on the same server, restart your 
server first to remove any residual files left after the previous installation.

• After you uninstall Installation Manager, restart your server, otherwise, the 
imsss.dll component remains in a deleted state, and reinstallation is corrupted. 
Restarting your server removes the Installation Manager subsystem, making it 
ready for a new install.



C H A P T E R  4

Setting Up the Packaging 
Environment

This chapter describes how to set up an environment in which you can run Packager 
and accurately capture an application installation for your target servers by creating 
ADF packages. The sections in this chapter describe what Packager is, how to set 
up a clean environment in which to run Packager, and how to restore the packaging 
server to its original condition after recording and packaging the application.

Note If you have not installed Packager, see “Installing Installation Manager” on 
page 17 for installation instructions.

This chapter covers the following topics:

• How Packager works

• The Packager components

• Creating a package

• Returning the Packager server to its original state

Installing applications on a Windows server is dependent on two major factors: the 
type of operating system on which you install the application and the freshness of 
that operating system. A single application performs disparate setup routines 
depending on the operating system under which the application is installed.

Packaging application installations on a Packager server requires a dedicated 
partition and a fresh operating system installation.
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Important The operating system for the Packager server must be a fresh 
installation with no changes made to it by any other applications. Packaging on a 
fresh operating system ensures that the recorded installation portion of Packager 
performs all of its possible configuration actions. You can then reproduce that 
installation on your target servers with varying configurations and previously 
installed applications and be assured that all necessary installation routines replay in 
the correct order.

Installation routines for different applications often repeat the same steps too, 
including writing and deleting common registry keys, modifying common 
initialization (.ini) files, and placing shared .dll files in common directories. 

For example, if you install an application that copies a dll file to a system directory 
and later you install a second application that copies the same dll file to the same 
system directory, the second application recognizes that the dll file already exists 
and does not attempt to replace it (depending on the version of the .dll file). 

To record an application installation accurately for reproduction on your target 
servers, you must package the application in an environment that runs the same 
operating system as your target servers.

How Packager Works
Packager is an application that monitors application installation routines. Packager 
monitors an application installation’s changes on the packaging server, records the 
changes as installation commands in a script, and then packages all application files 
so you can deploy the package on target servers.

Projects and Packages
The first time you open Packager (see “Creating an ADF Package” on page 40), a 
Project wizard appears to guide you through the packaging process.

Before you create an ADF package, you must create a project to which you assign a 
project name. The project can include the recording of an application’s installation 
by installing the application and collecting information about the application’s 
environment, resources, and components. Packager analyzes the information and 
stores it in a recorder log file. Packager then uses the log file to create an ADF file 
and to copy the installed application files to a package folder.
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After you create the project, you add components to the project—the application or 
other files, the ADF, and the ADF support files. Packager then builds these 
components into a package. When you create a package, you can choose to add the 
package to the Management Console and later install the package on the selected 
target servers. The project stays in Packager and can be edited any time (by adding 
or deleting files), unless you roll back Packager or delete the project.

The ADF File
Packager creates an ADF text file that contains information about the environment, 
resources, and files required to install and run an application on a server. The file 
name reflects the name of the target application with the extension .wfs (for 
example, Winword.wfs). The Installer Service uses the ADF file to recreate the 
installation on the target server.

ADF Parameters
The ADF parameters allow you to customize an ADF file at the command line. 
Using the ADF parameters you can:

• Install an application without using the product CD-ROM

• Repair a damaged application

• Remove or uninstall an application

• Describe the application and its requirements

• Inform the Installer Service how to access the application files

See the Advanced packaging features book in the online help in Packager for 
information about ADF creation, format, and syntax.

ADF Limitation
The ADF file has a limitation: the recording of an ADF file cannot always detect 
the intent of the install program when the registry keys change. To take advantage 
of the full intent of the application developer’s logic, such as reference counts to the 
dll files, Citrix recommends that you use the Add Unattended Program option in 
Packager if Setup has a silent install option.

See the online help in Packager for information about the ADF file or an unattended 
program.
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Using the Packager Window
This section describes the Packager main window and provides basic steps for 
creating a package. See the online help in Packager for more detailed information 
about how to create a package.

For most ADF packages, you will:

• Create a new project

• Record the application setup

• Add other necessary components to the project

• Build the package

• Copy the package to a network share point

" To start Packager

1. From the Start menu, click Programs > Citrix > Installation Manager > 
Packager.

2. Before you build a package, you must create a new project when you run 
Packager, either by selecting Create a new project using project wizard from 
Packager’s Project dialog box or from the File menu of Packager if the wizard 
is not displayed. 

When active, Packager displays a window with two panes.
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• The left pane displays a list of the possible items in the project known as the 
Packager tree.

• The right pane displays detailed information in columns about the item selected 
in the left pane. When you add components to the project, the details appear in 
this pane. You can edit some of the items in the left pane, but not all of them.
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Creating a Package
The following steps describe how to create a basic package. See the online help for 
more information.

" To create a new project, do one of the following:

• Use Packager’s Project Wizard

• On the File menu, click New Project

" To use the Project wizard

The Project wizard guides you through the process of adding your package 
components, adding a compatibility script if needed, building the package, and 
saving your package to a network share point so it can be managed from the 
Management Console.

1. From the File menu, click Project Wizard.

2. On the first page of the wizad, select one of the following options and click 
Next.

• Package an Installation Recording. This wizard records an application 
installation.

• Package an Unattended Program. This wizard installs an application 
without user intervention, such as a service pack or patch.

• Package Selected Files. This wizard packages other files, such as a service 
pack.

3. Click through the wizard screens and add each of your components.

4. Click OK to finish.

" To create a package without using the Project wizard

This procedure describes how to create a simple package manually. You must create 
a project before you build the package.

See the online help for detailed information about each step.

1. If the Project dialog box opens when you start Packager, click Cancel to close 
it.

2. To create a new project, from the File menu, choose New Project and click 
OK. Name the project and specify the name of the project file.
To open an existing project, from the File menu, choose Open Project. 
Alternatively, in the Project dialog box, select the project to open and click 
Open.
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3. From the Project menu, choose Add Recording. 
When you start the installation of an application, Packager records the 
installation setup routine.

4. In the Start Recording dialog box, browse to the location of the application or 
choose the application.

5. (Optional) Click Advanced to customize your recording.

• Include the events for the selected drive

• Select the actions to include in the recording

6. Click Start.
The application installs and Packager records the installation.

7. Click Done when the recording finishes.

8. From the Tools menu, choose Build Options. 

9. Browse or type the UNC path to the network share point where the package will 
be located.

10. Select Add packages to the Installation Manager database if you want this 
package to be available in the Management Console after you create rights on 
the network share point and set up a network account. Selecting this option 
saves a step later.

11. Type the name of the Default server and click OK. The Default server can be 
any server in the server farm.

12. From the Project menu, choose Build Package.

13. (Optional) Click the Build tab at the bottom of the main Packager window to 
view the results of the build.

14. Check the network share point to see if the package is there.
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Example: Create an ADF Package
The general steps required to create an ADF package, add it to Installation 
Manager, and schedule it for installation on target servers are:

1. Make sure the Packager server is clean.

2. Start Packager.

3. Create a new project in Packager or use the Project wizard to guide you through 
Steps 3–5. See “Projects and Packages” on page 26 for information about 
projects.

Note Make sure you disable all sessions before you begin a recording.

4. Record the application setup. Only one recording is allowed for each package.

5. Build an ADF package and copy the package to a share point on the network.

6. Roll back the Packager server to its original state before the package was 
created.

7. Set up a user account in the Management Console with Read and Write 
permission to copy the package to a share point on the network.

8. Add the new package to the Installation Manager database using Packager or 
the Management Console.

9. Schedule a job to install the package on the target server.

10. View the result to determine if the installation was successful.

Creating ADF Packages of Legacy (Non-MSI) Applications
This method creates legacy application packages that you can install unattended. 
Legacy applications are generally applications not written for use on a multiuser 
system.

You can use the following options to build the components of your ADF package:

Add Recording. Record an application’s installation.

Add Compatibility Script. Merge application compatibility scripts.

Add Unattended Program. Install legacy applications directly by launching silent or 
unattended installations (such as service packs).

Add Files. Add one or more files to a package.



 Chapter 4 Setting Up the Packaging Environment 33

The following procedure gives you a basic understanding of how to create various 
packages.

Important Make sure you use a clean Packager server before recording your 
installation.

" To create packages for legacy applications

1. Launch Packager.

2. From the File menu, choose New Project to create a new project for your 
package. Enter the project name and location.

3. (Optional.) To record the application’s installation, from the Project menu, 
choose Add Recording. Browse to the application you want to record and add 
the application to the package.

Note The recording does not continue if a restart is required during an 
application installation unless your application supports an unattended 
installation. If you do not want your application to restart the server (which 
stops the recording process), choose No when the application prompts you to 
restart. If you do not have a choice to restart, press ALT+TAB at the recording 
progress dialog box, then click Done and save the project. Click OK at the 
request to restart.

4. To choose the package location, from the Tools menu, choose Build Options. 
Browse to the location to which you want to copy the package.

Tip You can select Add packages to the Installation Manager database to 
copy this package to a network share point. Make sure the share point has the 
proper rights and that you set up the network account in the Management 
Console before you proceed to copy the file. Otherwise, you will have to add the 
package in the Management Console.

5. To build the package, from the Project menu, choose Build Package.

6. To view the build output messages, from the View menu, choose Output at the 
bottom of the Packager window.



34 Installation Manager for MetaFrame XP Administrator’s Guide

Creating ADF Packages that Include Other Files
This procedure explains how to add specific files for updates to legacy applications. 
An installation script is not needed in this procedure.

" To create installation packages using one or more files

1. Launch Packager.

2. From the File menu, choose New Project to create a new project for your 
package.

3. To add the files, from the Project menu, choose Add Files. Browse to and 
select the files you want to include in the package.

4. To choose the package location, from the Tools menu, choose Build Options. 
Browse to the location to where you want to copy the package.

Tip You can select Add packages to the Installation Manager database to 
copy this package to a network share point. Make sure that you set up the 
network account in the Management Console.

5. To build the package, from the Project menu, choose Build Package.

6. To view the build output messages, ensure that View > Output is checked. Any 
messages appear at the bottom of the main Packager window.

Creating ADF Packages of Applications that Include a 
Silent Install
This method allows you to install applications using the application vendor’s 
defaults (called a silent install). Use this method when your input is not required to 
install the package.

" To create installation packages using the defaults

1. Launch Packager.

2. From the File menu, choose New Project to create a new project for your 
package.

3. Add the unattended program. From the Project menu, choose Add Unattended 
Program.

4. To choose the package location, from the Tools menu, choose Build Options. 
Browse to the location to where you want to copy the file.
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Tip You can select Add packages to the Installation Manager database to 
copy this package to a network share point. Make sure that you set up the 
network account in the Management Console. If you add your package using 
this option, you do not have to add the package in the Management Console.

5. To build the package, from the Project menu, choose Build Package.

6. From the View menu, choose Output to view the history.

The left pane displays the project name and all data that you added to this project.

Adding Packages to the Installation Manager Database
This method allows you to schedule and install an ADF or MSI package on a target 
server from the Management Console.

Note Make sure that proper administrative rights are set up for your domain, that 
the user account is set up for the person who will be adding and installing the 
package on the target servers, and that file sharing is allowed for the package you 
add.

" To add the package

1. On the desktop, open the Management Console.

2. Log on to the server farm.

3. In the tree view, right-click Installation Manager and choose Properties.

4. Click the Network Account page. 

• In the User Name box, type the account name or click Browse to add the 
account name. 
If you click Browse, in the Look in list, choose the domain name and choose 
an account name from the list.

• In the Password box, type the password.

• In the Verify Password box, type the same password again.

• Click OK.

5. Click to expand the Installation Manager item in the tree view.

6. Click to expand Packages and the package group if applicable.
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Note If you create a package group, you can view the packages and 
applications in each package by clicking the package group, and then the 
package.

7. Right-click Packages and choose Add Package.

• In the Package Name box, enter a unique name for the package.

• In the File box, enter the pathname of the package that you want to add or 
click Browse to locate the file. Look for the package with the .wfs or .msi 
extension.

• Click OK twice. The package appears in the Packages or Package Groups 
item in the tree.

8. To install the package, right-click the package item and select Install Package.

9. Select the operating system platform on which to install the package.

10. Select a server on which to install the package and click Add.

11. Click Next.

12. To schedule the installation, specify the date and time to install the package in 
the Schedule Details dialog box. 

Tip You can view the package and all of the servers that you selected for the 
package in Schedule Targets.

13. (Optional) You can force the target server to restart after the package installation 
by selecting Force reboot after install.

14. Click Finish.

15. To view the results, click the package in the tree and click the Jobs tab.



 Chapter 4 Setting Up the Packaging Environment 37

Restoring the Packager Server to its Original State
Use Packager to restore your operating system to its original state before you 
created your project and built your ADF package. Perform this task every time you 
create a new package.

" To roll back your operating system to a clean state

1. Launch Packager.

2. From the Tools menu, choose Rollback.

3. Select the project that you want to roll back.

4. Click Rollback to roll back the session or click Delete to remove the session 
permanently.

5. Click Yes.

6. Click Close.





C H A P T E R  5

Deploying Applications Using 
Installation Manager

This chapter gives you an overview for using Installation Manager to plan and 
deploy packaged applications on your target servers. See the online help in the 
Management Console and in Packager for detailed information about performing 
the tasks in this chapter.

This chapter covers the following topics:

• Creating an ADF package

• Setting up rights on the network and in the domain

• Copying the package to a network share point

• Adding the package to Installation Manager

• Scheduling the deployment

• Publishing the application

Installation Manager expedites application installations on target servers so that 
Citrix MetaFrame users can run the published applications they need and use the 
most current software versions available. Packaging an application or other 
software can be performed in your company or you can purchase pre-packaged 
applications from a software manufacturer such as Microsoft.
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Creating an ADF Package
Use Packager to create an ADF package. 

In general, the Packager installation setup program performs these tasks as it creates 
an ADF package:

• Adds, modifies, and deletes registry keys

• Adds and modifies initialization (ini) files

• Creates desktop shortcuts

• Copies other program files such as executables and Dynamic Link Libraries 
(.dll files) to servers during application installations 

Packager records all such tasks so that Installation Manager can reproduce the 
application installation by replaying the recorded tasks on your target servers. This 
process ensures that the installation is complete and accurate. Recording an 
installation routine is called packaging an application. Packager executes an 
application’s setup program while running in the background.

When you package an application, Packager creates an installation script plus 
copies of the application files to install. The installation script is a text file that 
provides instructions to the Installer Service about how to install the application on 
the target servers. In this script, Packager uses a script language to record all of the 
installation tasks that the target servers can interpret and execute when replaying the 
installation.

Note This section does not give you step-by-step instructions about how to create 
an ADF package. Use the online help in Packager for specific details or see “Setting 
Up the Packaging Environment”on page 25.

Not all applications can be packaged. For example, you cannot package 
applications that require components or files to be downloaded from the Internet as 
part of the installation process. To determine if you can package an application, run 
the application’s Setup.exe file in Packager. If the application does not record, the 
installation likely will fail when deployed.

Note Make sure the application that you are trying to package is not already 
packaged as an ADF or MSI file. If it is, do not package it again. Some MSI files 
may not be easy to identify in an application suite. For best results, search for a file 
with the .msi extension.

See the Application Compatibility Guide for a list of popular applications that were 
tested using Packager and in which issues were found.
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Setting Up Access to Copy, Retrieve, and Install Packages
After you create a package, you must copy the package to a network share point. 
Before you do that, you must set up rights by performing the following tasks:

Network Share Point Setup. Read and write permissions must be set at the network 
share point to allow you to copy packages to that share point and retrieve them for 
deployment on the target servers. The user accounts for adding and retrieving 
packages must have local administrative rights. See the Windows documentation 
for more information.

Domain Administrator Setup. You must be a MetaFrame or domain administrator to 
run Installation Manager. See the Windows documentation for more information.

Network Account Setup. You must set up a network account in the Management 
Console. Use the Installation Manager Properties page in the Management Console 
to set up this account before you begin copying packages. Otherwise, the first time 
you add a package to the Installation Manager database, a Network Account dialog 
box opens, allowing you to set up a network account.

See the online help in the Management Console for more information.
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Copying a Package to a Network Share Point
You must copy an existing package to a network share point before you can add the 
package to Installation Manager in the Management Console and schedule the 
package for deployment on your target servers. Copying the package to a share 
point makes it accessible from the Management Console.

Copying MSI Packages
You can copy an MSI package manually to the network share point.

Note Microsoft recommends that MSI packages be installed on a share point 
using the following command at the command line: msiexec /a <package name>. 
This command string uncompresses the cabinet file (.cab) and allows you to set 
package properties such as the product ID. After entering the command, the 
software prompts you for the share point to the package.

Copying ADF packages
Installation Manager allows you to copy an ADF package to the network share 
point in two ways:

• Use the Tools menu. If you create an ADF package in Packager, Build Option 
allows you to copy the package to the network share point and add it to the 
Installation Manager database during package creation. Select the Add package 
to the Installation Manager database option and enter the path to a 
MetaFrame server. 

• Copy the file manually.

Adding a Package to Installation Manager
You must add packages to the Installation Manager database before you can install 
them. You can use the Add Package option in the Management Console to add 
your package to the Installation Manager database or you can add an ADF package 
in Packager.

The Management Console. You can add ADF, MSI, or MSP packages using the 
Add Package > Installation Manager option in the Management Console. This 
option can be accessed from the Actions menu when the Packages node is selected 
in the Management Console, or by right-clicking on the Packages node.

See the help in the Management Console for more information.



 Chapter 5 Deploying Applications Using Installation Manager 43

Packager. You can also add an ADF package in Packager by selecting the Add 
package to the Installation Manager database option during the build process. 

Scheduling a Package to Install
The Management Console and IMA allow management of MetaFrame XP servers 
and server farms from any location. Administrators with proper credentials can run 
the Management Console on any connected Windows 2000 Server or Windows 
Server 2003 (Windows NT Server 4.0 is not supported in MetaFrame XP Feature 
Release 2 or later).

With the Management Console installed, Installation Manager Setup installs the 
files necessary for IMA protocol communication on any supported workstation or 
server. The Management Console lets you set up network rights and add, install, 
and schedule packages for installation on your target servers. You can schedule an 
uninstall of an ADF or MSI package in the Management Console also. When you 
schedule a package, it becomes a job.

Installation Manager allows you to schedule a package installation in four ways 
using the Management Console:

Packages and Package Groups Item. Expand Installation Manager in the 
Management Console tree and right-click Packages in the Management Console 
tree or on the Contents tab to add a package or create a package group. Select a 
package or package group and choose Install Package. The Schedule Install 
dialog box appears.
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Applications Item. Right-click Applications and choose Publish Application.

Drag and Drop. Drag and drop a package item onto a server or server group in the 
Management Console tree or on the Contents tab. The Schedule Install dialog 
appears.

Server and Server Groups. Right-click a server or server group node in the 
Management Console tree or Content tab. Choose Install Package. The Package 
Selection panel appears.

See the help in the Management Console for information about scheduling a 
package installation.

Publishing a Packaged Application
Publishing applications is a major use of Installation Manager. The Application 
Publishing wizard lets you create connection items, called published items that 
point to specific applications on your servers.

You can use the MetaFrame XP Application Publishing wizard to install and 
publish applications automatically on any server in the farm.
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Using Application Publishing to Deploy Packages
When a Citrix MetaFrame user connects to a published application, the software 
initiates an ICA session containing the application specified during application 
publishing. To the Citrix MetaFrame user, a published application appears to be 
running locally. The user doesn’t need to know the name or address of the 
MetaFrame server executing the application. 

In Installation Manager, you can use the Applications item in the Management 
Console tree to install and publish a packaged application (after you add the 
package to the Installation Manager database). When you request to publish an 
application in Publish Application, you can select Installation Manager Package, 
then select the application to install on the selected target server in the same session.
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The Packaged Application box lists all of the files in the package. You can select 
any one of the files to install the package.

Using Packages that Contain the Same Applications
Installation Manager uses preferred packages. Various packages on the network can 
and often do contain the same applications. MSI packages usually contain a suite of 
applications, such as Microsoft Office 2000. The packages may be different, for 
example, if you add a compatibility script or a transform file to the package during 
the package build process.

For example, you may want to install a specific application suite that includes 
Microsoft Word and Microsoft Excel and another package that contains Microsoft 
Word only. You can designate one of the packages as a preferred package in 
Installation Manager. When the user selects Microsoft Word, the application in the 
preferred package is started. The Installation Manager Package option in 
Application Publishing lets you install and publish the preferred package, or you 
can use the Installation Manager item in the Management Console tree.
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Note The Installation Manager node cannot publish the application automatically 
after installation. Use Applications in the Management Console tree.

See the Installation Manager online help in the Management Console for more 
information about how to set up preferred packages.

Unpublishing an Application
Unpublishing an application installed with Installation Manager does not result in 
the application being uninstalled from the target server. Uninstalling the application 
or package from that server, however, both uninstalls and unpublishes the 
application. Use the Management Console to uninstall a packaged application 
installed using Installation Manager.

See the MetaFrame XP Server Administrator’s Guide for more information about 
unpublishing an application.

Note If you uninstall a program on a target machine locally without the use of 
Installation Manager, the program may still appear to be installed in the 
Management Console.
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Glossary

ADF file See Application Deployment File.

ADF package An installation package that includes the Installer Service script file and 
all of the support files necessary to complete an installation without user 
intervention. ADF packages are built using Packager.

application compatibility script A file containing commands and registry settings 
necessary for some applications to run in multisession environments such as 
Windows 2000 Server.

Application Deployment File A script file that describes steps used by the Installer 
Service to install applications in the Application Deployment File (ADF) 
package without user intervention. The format of the Installer Service script 
file interpreted and generated by Packager that contains installation 
information such as packaged files and directories plus registry settings.

application package An ADF or MSI package that includes the instructions and files 
to complete installation without user intervention.

Application Publishing wizard A tool that you use to publish applications and other 
items on MetaFrame servers.

attended machine A server with a logged-on user who can respond to system prompts.

Citrix ICA Client Citrix software that enables users to connect to MetaFrame servers 
from a variety of client devices.

ICA The acronym for Independent Computing Architecture. The architecture that 
Citrix uses to separate an application’s logic from its user interface. With ICA, 
only the keystrokes, mouse clicks, and screen updates pass between the client 
and server on the network, while 100 percent of the application’s logic 
executes on the server.

Independent Management Architecture (IMA) Citrix’s server-to-server infrastructure 
that provides robust, secure, and scalable tools for managing any size server 
farm. Among other features, IMA enables centralized platform-independent 
management, an ODBC-compliant data store, and a suite of management 
products that plug into the Management Console.
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Installation Manager Subsystem The software component that controls scheduling and 
initiates an installation on a target server.

Installation Manager A MetaFrame XPe feature type that allows administrators to 
install packaged applications on target servers from a single server running the 
Management Console. Installation Manager runs on IMA.

installation script An editable text file with a .wfs extension that describes the steps for 
the Installer Service to install an application in an ADF package without user 
intervention. In an installation script, Packager records all installation 
activities using a script language that the Installer Service can interpret and 
execute to reproduce the installation.

Installer Service A service that runs on a MetaFrame server using IMA. The Installer 
Service executes a request to install ADF or MSI packages without user 
intervention.

job A package that is scheduled for installation or uninstallation. 

Management Console The extensible, platform-independent tool for administering 
MetaFrame servers and management products.

MetaFrame administrator A system administrator who is responsible for installing, 
configuring, and maintaining MetaFrame servers.

mixed mode The mode of operation in which MetaFrame XP and MetaFrame 1.8 
servers are able to function together in the same farm. Not all MetaFrame XP 
features are available in mixed-mode operation.

MSI package An installation package based on Microsoft’s Windows Installer Service. 
MetaFrame XP is an example of a suite that ships as an MSI package for 
installation on target servers.

package See application package.

package group A group of ADF or MSI packages used for easier application 
deployment on target servers.

Packager An application that monitors the changes that an application's installation 
makes on a server, records those changes as installation commands in an ADF 
file, and packages all the required support files for distribution on target 
servers.

preferred package A package that may contain the same application as another 
package, but one that must be used to deploy on specific target servers.

project A container to package components for an ADF package. A project includes 
the application and any other files added to the project in which the package 
can be built.

published application An application installed on a MetaFrame server or server farm 
that is configured for multiuser access from Citrix ICA Clients.

record log file A log file of file system and registry changes recorded during an 
application installation. 



 Appendix A Glossary 51

recorder A feature of Packager that records installation events.

rollback 1. An action that restores the file system and registry settings to the initial 
condition prior to recording an installation using Packager. 2. An action that 
restores the file system and registry to its initial state if an error occurs during 
the installation of an MSI package.

server farm A group of MetaFrame servers managed as a single entity, with some 
form of physical connection between servers and an IMA-based data store.

server group A group of servers used for easier application deployment on target 
servers.

silent install See unattended install.

target server The server on which ADF or MSI packages are installed by the 
Management Console and the Installer Service.

transform file A database that can modify an MSI database without changing the MSI 
file. For example, Microsoft Office cannot run in a Terminal Services 
environment without the addition of a transform file.

unattended install An installation type that does not require user intervention during 
application installations.

unattended server A server that does not require user intervention during application 
installations.
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Index

A
Add Compatibility Script option

Packager 32
Add Files option

Packager 32
Add Package option 42
Add packages to Installation Manager database option 34
Add Recording option

Packager 32
Add Unattended Program option 34
adding a package to Installation Manager 42
ADF limitations 27
ADF packages

about 13
adding files 34
copying to a sharepoint 42
creating 40
defined 49

ADF parameters 27
ADF, and Packager 27
allow 43
Application Deployment File 26, 32

defined 49
application package, defined 49
Application publishing 11
Application Publishing wizard 44
Application Publishing wizard, defined 49
applications, adding packages using the defaults 34

B
Build Options 34

C
Citrix Documentation Library 8
Citrix ICA Client 45
Citrix ICA Clients, downloading 8
Citrix Web site 8
compatibility script

defined 49
conventions, documentation 7
creating an ADF package 33

D
desktop shortcuts and Packager 40
determining package format 13
dlls and Packager 40
documentation

conventions 7
using PDF 7

domain account, Windows NT 19

E
environment settings for Installation Manager 20

F
Feature Release

uninstalling 23
files

adding to a package 34
Frequently Asked Questions 8

G
granting access to Installation Manager 23

I
ICA

Client, defined 49
connections, asynchronous 49
defined 49

IMA 43
defined 49

Independent Management Architecture
see IMA

install
package 35



54 Installation Manager for MetaFrame XP Administrator’s Guide

Installation Manager
components 12
database 35
documentation 6
features 11
granting access 23
installing 17, 20, 39
MetaFrame XP 44
overview 11
requirements 17
Subsystem, defined 50
welcome 5

installation script 40
defined 40, 50

Installer service
defined 50

J
Jobs tab 36

M
Management Console

adding ADF packages 35
defined 50
features 22
starting 22

MetaFrame administrator, defined 50
MetaFrame XP

Application publishing 44
MetaFrame XP server requirements 18
mixed mode, defined 50
MSI package

copying to a sharepoint 42
defined 50

N
Network Account page, Management Console 35
network sharepoint

copying packages 42
requirements 17, 19

P
package

components 32
defined 40, 50

package format
determining 13

package group, defined 50
Packager

defined 49
introduction 40
items in the tree 40
Project wizard 26
restoring the operating system 37
what it does 40
what it is 26

packages
adding ADF 35
creating legacy applications 32
preferred 46

package, scheduling for deployment 43
packaging

overview 25
partition requirements 18
requirements 18
setting up 25

preferred package 46
preferred package, defined 50
Project wizard

Packager 26
project, defined 50
Publish Application

Installation Manager 11

R
record log file, defined 50
recorder, defined 51
recording an installation 32
registry keys and Packager 40
requirements 17

general 17
MetaFrame server 19
packaging 18

restoring the Packager operating system 37
rollback 32

defined 51
Rollback option

Packager 37

S
scheduling a package for deployment 43
server farm, defined 51
server group, defined 51
sharepoint

copying packages 42
sharepoint, setting up 23
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silent install 34
silent install, defined 51
Solution Knowledge Base 8

T
target server

defined 51
transform file 14

defined 51

U
unattended install, defined 51
unattended server, defined 51
uninstalling Feature Release 23
unpublishing an application 47

W
Welcome 5
Windows NT Server 4.0, and Feature Release 2 43
Windows NT sharepoint 19
.ini files and Packager 40
.wfs file 27
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